about summary refs log tree commit diff
path: root/pkgs
diff options
context:
space:
mode:
authorPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2021-03-16 09:45:49 +0100
committerPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2021-03-16 09:45:49 +0100
commit9bd9de93e1c9e7aa960881e5b578064f9bae16d5 (patch)
treee539b37fb1bf7723804a0c54a4c6474d39d573ce /pkgs
parent42675b1999eb1e95a3bc129ea215d6a6b8e6f540 (diff)
downloadpnpkgs-9bd9de93e1c9e7aa960881e5b578064f9bae16d5.tar.gz
pnpkgs-9bd9de93e1c9e7aa960881e5b578064f9bae16d5.zip
Add config to dwmblocks
Diffstat (limited to 'pkgs')
-rw-r--r--pkgs/larbs/dwmblocks/default.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/pkgs/larbs/dwmblocks/default.nix b/pkgs/larbs/dwmblocks/default.nix
index 560ed14..3277cc0 100644
--- a/pkgs/larbs/dwmblocks/default.nix
+++ b/pkgs/larbs/dwmblocks/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchgit, libX11, patches ? [] }:
+{ stdenv, fetchgit, libX11, config_h ? null, patches ? [] }:
 
 with stdenv.lib;
 
@@ -15,6 +15,10 @@ stdenv.mkDerivation rec {
 
   buildInputs = [ libX11 ];
 
+  prePatch = ''
+    ${stdenv.lib.optionalString (config_h) "cp ${config_h} config.h"}
+  '';
+
   installPhase = ''
     make install PREFIX=$out
   '';