about summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--pkgs/larbs/dwmblocks/default.nix6
1 files changed, 5 insertions, 1 deletions
diff --git a/pkgs/larbs/dwmblocks/default.nix b/pkgs/larbs/dwmblocks/default.nix
index 560ed14..3277cc0 100644
--- a/pkgs/larbs/dwmblocks/default.nix
+++ b/pkgs/larbs/dwmblocks/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchgit, libX11, patches ? [] }:
+{ stdenv, fetchgit, libX11, config_h ? null, patches ? [] }:
 
 with stdenv.lib;
 
@@ -15,6 +15,10 @@ stdenv.mkDerivation rec {
 
   buildInputs = [ libX11 ];
 
+  prePatch = ''
+    ${stdenv.lib.optionalString (config_h) "cp ${config_h} config.h"}
+  '';
+
   installPhase = ''
     make install PREFIX=$out
   '';