about summary refs log tree commit diff
diff options
context:
space:
mode:
authorPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2020-10-07 17:34:12 +0200
committerPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2020-10-07 17:34:12 +0200
commitb0086e0c0e8ea2a2eb24810e0fda00b956325469 (patch)
tree870417eb0e83deaa798abb1edb1a9961b260da9b
parentba13c42ba85ac3973bbe77a8aa119a11083cb26c (diff)
downloadpnpkgs-b0086e0c0e8ea2a2eb24810e0fda00b956325469.tar.gz
pnpkgs-b0086e0c0e8ea2a2eb24810e0fda00b956325469.zip
Add simple-mtpfs and task-spooler
-rw-r--r--default.nix1
-rw-r--r--pkgs/simple-mtpfs/default.nix44
-rw-r--r--pkgs/task-spooler/default.nix27
3 files changed, 72 insertions, 0 deletions
diff --git a/default.nix b/default.nix
index b09dac6..5f0b479 100644
--- a/default.nix
+++ b/default.nix
@@ -18,6 +18,7 @@
   libthinkpad = pkgs.callPackage ./pkgs/libthinkpad { };
   dockd = pkgs.callPackage ./pkgs/dockd { };
   simple-mtpfs = pkgs.callPackage ./pkgs/simple-mtpfs { };
+  task-spooler = pkgs.callPackage ./pkgs/task-spooler { };
 
   st = pkgs.callPackage ./pkgs/larbs/st { };
   dwm = pkgs.callPackage ./pkgs/larbs/dwm { };
diff --git a/pkgs/simple-mtpfs/default.nix b/pkgs/simple-mtpfs/default.nix
new file mode 100644
index 0000000..06c685a
--- /dev/null
+++ b/pkgs/simple-mtpfs/default.nix
@@ -0,0 +1,44 @@
+{ stdenv, fetchgit, pkgconfig, autoconf, autoconf-archive, automake, libmtp, fuse }:
+with stdenv.lib;
+let
+  pname = "simple-mtpfs";
+  version = "0.4.0";
+in
+  stdenv.mkDerivation {
+    inherit pname version;
+
+    nativeBuildInputs = [
+      autoconf
+      autoconf-archive
+      automake
+      pkgconfig
+    ];
+
+    buildInputs = [
+      libmtp
+      fuse
+    ];
+
+
+    src = fetchgit {
+      url = "https://github.com/phatina/simple-mtpfs";
+      rev = "v${version}";
+      sha256 = "00nj2c1hf37d9r0rdbc77k3q62iw4hyfvlifxx5b5q0sikda42mw";
+    };
+
+    buildPhase = ''
+      ./autogen.sh
+      mkdir build
+      ./configure
+      make
+    '';
+
+    installPhase = ''
+      make install prefix=$out
+    '';
+
+    meta = {
+      homepage =  "https://github.com/phatina/simple-mtpfs";
+      description = "Simple MTP fuse filesystem driver.";
+    };
+  }
diff --git a/pkgs/task-spooler/default.nix b/pkgs/task-spooler/default.nix
new file mode 100644
index 0000000..69aebd3
--- /dev/null
+++ b/pkgs/task-spooler/default.nix
@@ -0,0 +1,27 @@
+{ stdenv, fetchurl }:
+with stdenv.lib;
+
+let
+  pname = "task-spooler";
+  version = "1.0";
+in
+  stdenv.mkDerivation {
+    inherit pname version;
+
+    src = fetchurl {
+      url = "http://vicerveza.homeunix.net/~viric/soft/ts/ts-${version}.tar.gz";
+      sha256 = "15dkzczx10fhl0zs9bmcgkxfbwq2znc7bpscljm4rchbzx7y6lsg";
+    };
+
+    installPhase = ''
+      mkdir -p $out/bin $out/share/man/man1 $out/share/doc/task-spooler
+      cp ts $out/bin/tsp
+      cp ts.1 $out/share/man/man1/tsp.1
+      cp TRICKS $out/share/doc/task-spooler/TRICKS
+    '';
+
+    meta = {
+      description = "Queue up tasks from the shell for batch execution";
+      license = licenses.gpl3;
+    };
+  }