about summary refs log tree commit diff
path: root/pkgs/simple-mtpfs/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/simple-mtpfs/default.nix')
-rw-r--r--pkgs/simple-mtpfs/default.nix44
1 files changed, 44 insertions, 0 deletions
diff --git a/pkgs/simple-mtpfs/default.nix b/pkgs/simple-mtpfs/default.nix
new file mode 100644
index 0000000..06c685a
--- /dev/null
+++ b/pkgs/simple-mtpfs/default.nix
@@ -0,0 +1,44 @@
+{ stdenv, fetchgit, pkgconfig, autoconf, autoconf-archive, automake, libmtp, fuse }:
+with stdenv.lib;
+let
+  pname = "simple-mtpfs";
+  version = "0.4.0";
+in
+  stdenv.mkDerivation {
+    inherit pname version;
+
+    nativeBuildInputs = [
+      autoconf
+      autoconf-archive
+      automake
+      pkgconfig
+    ];
+
+    buildInputs = [
+      libmtp
+      fuse
+    ];
+
+
+    src = fetchgit {
+      url = "https://github.com/phatina/simple-mtpfs";
+      rev = "v${version}";
+      sha256 = "00nj2c1hf37d9r0rdbc77k3q62iw4hyfvlifxx5b5q0sikda42mw";
+    };
+
+    buildPhase = ''
+      ./autogen.sh
+      mkdir build
+      ./configure
+      make
+    '';
+
+    installPhase = ''
+      make install prefix=$out
+    '';
+
+    meta = {
+      homepage =  "https://github.com/phatina/simple-mtpfs";
+      description = "Simple MTP fuse filesystem driver.";
+    };
+  }