summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..9e576c3
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,24 @@
+{
+  description = "19 PDH Puszcza low-tech site";
+  inputs.nur.url = github:nix-community/NUR;
+
+  outputs = { self, nixpkgs, nur }:
+  let
+    system = "x86_64-linux";
+    pkgs = import nixpkgs { inherit system; overlays = [ nur.overlay ]; };
+  in {
+    defaultPackage.${system} = self.packages.${system}.low-puszcza;
+
+    packages.${system}.low-puszcza = pkgs.stdenv.mkDerivation {
+      name = "low-puszcza";
+      src = self;
+      nativeBuildInputs = [ pkgs.zip pkgs.nur.repos.pn.saait ];
+
+      installPhase = ''
+        mkdir $out
+        cp -r output $out/
+      '';
+    };
+
+  };
+}