about summary refs log tree commit diff
path: root/pkgs
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs')
-rw-r--r--pkgs/agate/default.nix26
1 files changed, 26 insertions, 0 deletions
diff --git a/pkgs/agate/default.nix b/pkgs/agate/default.nix
new file mode 100644
index 0000000..eb5a47c
--- /dev/null
+++ b/pkgs/agate/default.nix
@@ -0,0 +1,26 @@
+{ stdenv, rustPlatform, fetchFromGitHub }:
+with stdenv.lib;
+
+let
+  pname = "agate";
+  version = "1.2.2";
+in
+rustPlatform.buildRustPackage {
+  inherit pname version;
+
+  src = fetchFromGitHub {
+    owner = "mbrubeck";
+    repo = pname;
+    rev = "v${version}";
+    sha256 = "0kfr0xysxh830kxwfwmm9gzpl57b3dbkzrj21dnymwr117vjgjrx";
+  };
+
+  cargoSha256 = "1ggwc1q998mp6pggxrmhhvnkyrdh6jv1w9jw0x0y2mbn26k54j0p";
+
+  meta = {
+    description = "Very simple server for the Gemini hypertext protocol";
+    homepage = "https://github.com/mbrubeck/agate";
+    license = "MIT/Apache-2.0";
+    platforms = platforms.linux;
+  };
+}