about summary refs log tree commit diff
path: root/pkgs
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs')
-rw-r--r--pkgs/larbs/dwmblocks/default.nix4
1 files changed, 2 insertions, 2 deletions
diff --git a/pkgs/larbs/dwmblocks/default.nix b/pkgs/larbs/dwmblocks/default.nix
index 3277cc0..2718b6d 100644
--- a/pkgs/larbs/dwmblocks/default.nix
+++ b/pkgs/larbs/dwmblocks/default.nix
@@ -1,4 +1,4 @@
-{ stdenv, fetchgit, libX11, config_h ? null, patches ? [] }:
+{ stdenv, lib, fetchgit, libX11, config_h ? null, patches ? [] }:
 
 with stdenv.lib;
 
@@ -16,7 +16,7 @@ stdenv.mkDerivation rec {
   buildInputs = [ libX11 ];
 
   prePatch = ''
-    ${stdenv.lib.optionalString (config_h) "cp ${config_h} config.h"}
+    ${lib.optionalString (config_h != null) "cp ${config_h} config.h"}
   '';
 
   installPhase = ''