about summary refs log tree commit diff
path: root/pkgs
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs')
-rw-r--r--pkgs/xccp/default.nix15
1 files changed, 15 insertions, 0 deletions
diff --git a/pkgs/xccp/default.nix b/pkgs/xccp/default.nix
new file mode 100644
index 0000000..ba89a28
--- /dev/null
+++ b/pkgs/xccp/default.nix
@@ -0,0 +1,15 @@
+{ stdenv, fetchFromGitHub, libX11 }:
+stdenv.mkDerivation {
+  name = "xccp";
+
+  src = fetchFromGitHub {
+    repo = "xccp";
+    owner = "hohmannr";
+    rev = "42dac1a6cd7b0ba779c1770664e003371400c1f8";
+    sha256 = "1yw0g97r2irzbnwl6kj5p8f8s1iylm7yazfbi1kwhk55fazczq1v";
+  };
+
+  buildInputs = [ libX11 ];
+  buildPhase = "make CC=${stdenv.cc}/bin/gcc";
+  installPhase = "make install INSTALL_DIR=$out/bin";
+}