about summary refs log tree commit diff
path: root/pkgs/xcb-util/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/xcb-util/default.nix')
-rw-r--r--pkgs/xcb-util/default.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/pkgs/xcb-util/default.nix b/pkgs/xcb-util/default.nix
new file mode 100644
index 0000000..1189e62
--- /dev/null
+++ b/pkgs/xcb-util/default.nix
@@ -0,0 +1,24 @@
+{ stdenv, fetchzip, pkg-config, libxcb }:
+
+stdenv.mkDerivation rec {
+  pname = "xcb-util";
+  version = "0.4";
+
+  src = fetchzip {
+    url = "https://xcb.freedesktop.org/dist/xcb-util-0.4.0.tar.bz2";
+    sha256 = "1sahmrgbpyki4bb72hxym0zvxwnycmswsxiisgqlln9vrdlr9r26";
+  };
+
+  preConfigure = "./autogen.sh";
+
+  nativeBuildInputs = [ pkg-config ];
+  buildInputs = [ libxcb ];
+
+  meta = with stdenv.lib; {
+    homepage = "https://xcb.freedesktop.org/XcbUtil/";
+    description = "The xcb-util module provides a number of libraries which sit on top of libxcb, the core X protocol library, and some of the extension libraries";
+    license = licenses.isc;
+    maintainers = with maintainers; [ ];
+    platforms = platforms.linux;
+  };
+}