about summary refs log tree commit diff
path: root/pkgs/larbs/st
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/larbs/st')
-rw-r--r--pkgs/larbs/st/default.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/pkgs/larbs/st/default.nix b/pkgs/larbs/st/default.nix
new file mode 100644
index 0000000..fb3c4ee
--- /dev/null
+++ b/pkgs/larbs/st/default.nix
@@ -0,0 +1,29 @@
+{ stdenv, fetchgit, pkgconfig, writeText, libX11, ncurses, libXft, harfbuzzFull }:
+
+with stdenv.lib;
+
+stdenv.mkDerivation rec {
+  name = "st";
+
+  src = fetchgit {
+    url = "https://github.com/LukeSmithXYZ/st";
+    rev = "de6fd85eeb544548ed5ad23a639eedd6af510036";
+    sha256 = "1xyrbi857435dln7i6qb9ys2jizv43a2zq6fx4dr8z52ramxzyky";
+  };
+
+  nativeBuildInputs = [ pkgconfig ncurses ];
+  buildInputs = [ libX11 libXft harfbuzzFull ];
+
+  installPhase = ''
+    sed -i '/man/d' Makefile
+    sed -i '/tic/d' Makefile
+    TERMINFO=$out/share/terminfo make PREFIX=$out install
+  '';
+
+  meta = {
+    homepage = "https://github.com/LukeSmithXYZ/st";
+    description = "Luke's fork of the suckless simple terminal (st) with vim bindings and Xresource compatibility.";
+    license = licenses.mit;
+    platforms = platforms.linux;
+  };
+}