about summary refs log tree commit diff
path: root/pkgs/larbs/dwm/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/larbs/dwm/default.nix')
-rw-r--r--pkgs/larbs/dwm/default.nix29
1 files changed, 29 insertions, 0 deletions
diff --git a/pkgs/larbs/dwm/default.nix b/pkgs/larbs/dwm/default.nix
new file mode 100644
index 0000000..57ef1dc
--- /dev/null
+++ b/pkgs/larbs/dwm/default.nix
@@ -0,0 +1,29 @@
+{ stdenv, fetchgit, libX11, libXinerama, libXft, xlibs, patches ? [] }:
+
+with stdenv.lib;
+
+stdenv.mkDerivation rec {
+  name = "dwm";
+  version = "1.0";
+
+  src = fetchgit {
+    url = "https://github.com/LukeSmithXYZ/dwm";
+    rev = "28d87d439359096e2f03f2e8582a481269de06be";
+    sha256 = "1fi0q68zqcmnx4spvjaqlv0k43ij96bz3545qdlc077qhzw2lxxh";
+  };
+
+  buildInputs = [ libX11 libXinerama libXft xlibs.libXext.dev ];
+
+  prePatch = ''sed -i "s@/usr/local@$out@" config.mk'';
+
+  inherit patches;
+
+  buildPhase = ''make LDFLAGS="-L/usr/X11R6/lib -lX11 -lXinerama -lfontconfig -lXft -lX11-xcb -lxcb -lxcb-res -lXext"'';
+
+  meta = {
+    homepage = "https://github.com/LukeSmithXYZ/dwm";
+    description = "Luke's build of dwm";
+    license = stdenv.lib.licenses.mit;
+    platforms = with stdenv.lib.platforms; all;
+  };
+}