about summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--README.md13
-rw-r--r--pkgs/mutt-wizard/default.nix2
2 files changed, 14 insertions, 1 deletions
diff --git a/README.md b/README.md
index 4c76016..83e6b57 100644
--- a/README.md
+++ b/README.md
@@ -4,4 +4,17 @@
 
 [![Build Status](https://travis-ci.com/pniedzwiedzinski/pnpkgs.svg?branch=master)](https://travis-ci.com/pniedzwiedzinski/pnpkgs)
 
+## Larbs mail
 
+If you use [Luke's configuration](https://github.com/LukeSmithXYZ/mutt-wizard) of neomutt as your mail client, you can get it also on NixOS. Install `nur.repos.pn.larbs-mail` and all will be installed. !!! __You need to add this to your__ `/etc/nixos/configuration.nix` __file__:
+
+```nix
+environment.etc."neomuttrc".text = builtins.readFile "${pkgs.nur.repos.pn.mutt-wizard}/share/mutt-wizard/mutt-wizard.muttrc";
+```
+
+If you have already generated muttrc file in your home you will need to change first source line:
+
+```diff
+-source /usr/local/share/mutt-wizard/mutt-wizard.muttrc
++source /etc/neomuttrc
+```
diff --git a/pkgs/mutt-wizard/default.nix b/pkgs/mutt-wizard/default.nix
index badad4f..aa6d533 100644
--- a/pkgs/mutt-wizard/default.nix
+++ b/pkgs/mutt-wizard/default.nix
@@ -11,9 +11,9 @@ stdenv.mkDerivation rec {
     sha256 = "1bb9429wabv85zja2y89vhj15qcd10acbg5k6ylilw067wzs9ks5";
   };
 
-
   buildPhase = ''
     sed -i 's/(PREFIX)/(out)/g' Makefile
+    sed -i 's:mwconfig="\$muttshare/mutt-wizard.muttrc":mwconfig=/etc/neomuttrc:' bin/mw
     make PREFIX=$out SHELL=$SHELL install
   '';