about summary refs log tree commit diff
diff options
context:
space:
mode:
-rw-r--r--pkgs/larbs/st/default.nix9
1 files changed, 6 insertions, 3 deletions
diff --git a/pkgs/larbs/st/default.nix b/pkgs/larbs/st/default.nix
index 92621e9..10528f7 100644
--- a/pkgs/larbs/st/default.nix
+++ b/pkgs/larbs/st/default.nix
@@ -1,6 +1,7 @@
-{ stdenv, fetchgit, pkgconfig, writeText, libX11, ncurses, libXft, harfbuzzFull }:
+{ stdenv, lib, fetchgit, pkgconfig, writeText, libX11, ncurses, libXft, harfbuzzFull,
+conf ? null }:
 
-with stdenv.lib;
+with lib;
 
 stdenv.mkDerivation rec {
   name = "st";
@@ -16,7 +17,9 @@ stdenv.mkDerivation rec {
 
   patchPhase = ''
     sed -i 's/alpha = 0.8/alpha = 0.95/' config.h
-  '';
+  '' + optionalString (conf != null) ''
+      cp ${conf} config.h
+    '';
 
   installPhase = ''
     sed -i '/man/d' Makefile