about summary refs log tree commit diff
path: root/pkgs/xwallpaper
diff options
context:
space:
mode:
authorPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2020-09-06 18:10:04 +0200
committerGitHub <noreply@github.com>2020-09-06 18:10:04 +0200
commit6c9497740f910262178f6e39ef3e96ed87ecccbf (patch)
treeab49cf56a3c306cc164adb613e6928780c643417 /pkgs/xwallpaper
parentf6aa9a292a9b4885560e863f3c652282e4f3ca3b (diff)
downloadpnpkgs-6c9497740f910262178f6e39ef3e96ed87ecccbf.tar.gz
pnpkgs-6c9497740f910262178f6e39ef3e96ed87ecccbf.zip
Add xwallpaper
Diffstat (limited to 'pkgs/xwallpaper')
-rw-r--r--pkgs/xwallpaper/default.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/pkgs/xwallpaper/default.nix b/pkgs/xwallpaper/default.nix
new file mode 100644
index 0000000..2b8a5ee
--- /dev/null
+++ b/pkgs/xwallpaper/default.nix
@@ -0,0 +1,27 @@
+{ stdenv, fetchFromGitHub, pkg-config, autoreconfHook, pixman, xcbutil, xcbutilimage
+, libseccomp, libjpeg, libpng, libXpm }:
+
+stdenv.mkDerivation rec {
+  pname = "xwallpaper";
+  version = "0.6.5";
+
+  src = fetchFromGitHub {
+    owner = "stoeckmann";
+    repo = "xwallpaper";
+    rev = "v${version}";
+    sha256 = "121ai4dc0v65qk12gn9w62ixly8hc8a5qrygkbb82vy8ck4jqxj7";
+  };
+
+  preConfigure = "./autogen.sh";
+
+  nativeBuildInputs = [ pkg-config autoreconfHook ];
+  buildInputs = [ pixman xcbutilimage xcbutil libseccomp libjpeg libpng libXpm ];
+
+  meta = with stdenv.lib; {
+    homepage = "https://github.com/stoeckmann/xwallpaper";
+    description = "Utility for setting wallpapers in X";
+    license = licenses.isc;
+    maintainers = with maintainers; [] ;
+    platforms = platforms.linux;
+  };
+}