about summary refs log tree commit diff
path: root/default.nix
diff options
context:
space:
mode:
authorPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2020-08-09 16:14:36 +0200
committerPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2020-08-09 16:14:36 +0200
commit7b8b24292f84c982bd7b67ce2d7980561662fcc0 (patch)
tree1ec64c5b1a14cd7fafebfc2a9612952f969d14a3 /default.nix
downloadpnpkgs-7b8b24292f84c982bd7b67ce2d7980561662fcc0.tar.gz
pnpkgs-7b8b24292f84c982bd7b67ce2d7980561662fcc0.zip
Initial commit
Diffstat (limited to 'default.nix')
-rw-r--r--default.nix21
1 files changed, 21 insertions, 0 deletions
diff --git a/default.nix b/default.nix
new file mode 100644
index 0000000..46c4090
--- /dev/null
+++ b/default.nix
@@ -0,0 +1,21 @@
+# This file describes your repository contents.
+# It should return a set of nix derivations
+# and optionally the special attributes `lib`, `modules` and `overlays`.
+# It should NOT import <nixpkgs>. Instead, you should take pkgs as an argument.
+# Having pkgs default to <nixpkgs> is fine though, and it lets you use short
+# commands such as:
+#     nix-build -A mypackage
+
+{ pkgs ? import <nixpkgs> {} }:
+
+{
+  # The `lib`, `modules`, and `overlay` names are special
+  lib = import ./lib { inherit pkgs; }; # functions
+  modules = import ./modules; # NixOS modules
+  overlays = import ./overlays; # nixpkgs overlays
+
+  example-package = pkgs.callPackage ./pkgs/example-package { };
+  # some-qt5-package = pkgs.libsForQt5.callPackage ./pkgs/some-qt5-package { };
+  # ...
+}
+