about summary refs log tree commit diff
diff options
context:
space:
mode:
authorPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2020-08-09 21:14:05 +0200
committerGitHub <noreply@github.com>2020-08-09 21:14:05 +0200
commit20f71ac28518e255e347ae8238fa1d770ea8f277 (patch)
tree1b300bee36750ececfc5ef21a770cf466b76550a
parentb9d830cdee2e99cfdc80dbf4f53f64eca4c40e43 (diff)
downloadpnpkgs-20f71ac28518e255e347ae8238fa1d770ea8f277.tar.gz
pnpkgs-20f71ac28518e255e347ae8238fa1d770ea8f277.zip
Add Luke's dwm
-rw-r--r--pkgs/dwm/default.nix30
1 files changed, 30 insertions, 0 deletions
diff --git a/pkgs/dwm/default.nix b/pkgs/dwm/default.nix
new file mode 100644
index 0000000..2187996
--- /dev/null
+++ b/pkgs/dwm/default.nix
@@ -0,0 +1,30 @@
+{ stdenv, fetchgit, libX11, libXinerama, libXft, patches ? [] }:
+
+with stdenv.lib;
+
+stdenv.mkDerivation rec {
+  name = "dwm";
+
+  src = fetchgit {
+    url = "https://github.com/LukeSmithXYZ/dwm";
+    rev = "484720bbba3e2b175b71dba283c3a84b13e71eea";
+    sha256 = "1w19zy3c9nckrh9jwj30ijv7gl0miyiw4m287n5bxmm98zly264p";
+  };
+
+  buildInputs = [ libX11 libXinerama libXft ];
+
+  prePatch = ''sed -i "s@/usr/local@$out@" config.mk'';
+
+  # Allow users set their own list of patches
+  inherit patches;
+
+  buildPhase = " make ";
+
+  meta = {
+    homepage = "https://github.com/LukeSmithXYZ/dwm";
+    description = "Luke's build of dwm";
+    license = stdenv.lib.licenses.mit;
+    maintainers = with stdenv.lib.maintainers; [pniedzwiedzinski];
+    platforms = with stdenv.lib.platforms; all;
+  };
+}