about summary refs log tree commit diff
path: root/platforms/darwin/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'platforms/darwin/configuration.nix')
-rw-r--r--platforms/darwin/configuration.nix39
1 files changed, 0 insertions, 39 deletions
diff --git a/platforms/darwin/configuration.nix b/platforms/darwin/configuration.nix
deleted file mode 100644
index e168782..0000000
--- a/platforms/darwin/configuration.nix
+++ /dev/null
@@ -1,39 +0,0 @@
-{ config, pkgs, ... }:
-
-let
-  common_packages = import ../common-packages.nix pkgs;
-in
-{
-  # List packages installed in system profile. To search by name, run:
-  # $ nix-env -qaP | grep wget
-  environment.systemPackages = with pkgs; [
-    # Packages
-    hello
-  ]
-  ++ common_packages;
-
-  system.defaults.dock = {
-    orientation = "left";
-    autohide = true;
-    autohide-time-modifier = "1.0";
-    mineffect = "scale";
-    minimize-to-application = true;
-    static-only = true;
-  };
-
-  # Use a custom configuration.nix location.
-  # $ darwin-rebuild switch -I darwin-config=$HOME/.config/nixpkgs/darwin/configuration.nix
-  environment.darwinConfig = "$HOME/.config/nixpkgs/platforms/darwin/configuration.nix";
-
-  # Auto upgrade nix package and the daemon service.
-  # services.nix-daemon.enable = true;
-  # nix.package = pkgs.nix;
-
-  # Create /etc/bashrc that loads the nix-darwin environment.
-  programs.zsh.enable = true;  # default shell on catalina
-  # programs.fish.enable = true;
-
-  # Used for backwards compatibility, please read the changelog before changing.
-  # $ darwin-rebuild changelog
-  system.stateVersion = 4;
-}