about summary refs log tree commit diff
path: root/modules/slock.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/slock.nix')
-rw-r--r--modules/slock.nix18
1 files changed, 11 insertions, 7 deletions
diff --git a/modules/slock.nix b/modules/slock.nix
index 85c78de..d98e898 100644
--- a/modules/slock.nix
+++ b/modules/slock.nix
@@ -17,13 +17,17 @@ let
 in {
   environment.systemPackages = [ slock ];
   security.wrappers.slock.source = "${slock.out}/bin/slock";
-  services.xserver.xautolock = {
+  # services.xserver.xautolock = {
+  #   enable = true;
+  #   locker = "${config.security.wrapperDir}/slock";
+  #   enableNotifier = true;
+  #   notifier = "${pkgs.libnotify}/bin/notify-send \"Locking in 10 seconds\"";
+  #   killer = "/run/current-system/systemd/bin/systemctl suspend-then-hibernate";
+  #   killtime = 30;
+  #   extraOptions = [ "-detectsleep" ];
+  # };
+  programs.xss-lock = {
     enable = true;
-    locker = "${config.security.wrapperDir}/slock";
-    enableNotifier = true;
-    notifier = "${pkgs.libnotify}/bin/notify-send \"Locking in 10 seconds\"";
-    killer = "/run/current-system/systemd/bin/systemctl suspend-then-hibernate";
-    killtime = 30;
-    extraOptions = [ "-detectsleep" ];
+    lockerCommand = "${config.security.wrapperDir}/slock";
   };
 }