about summary refs log tree commit diff
path: root/modules/personal.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/personal.nix')
-rw-r--r--modules/personal.nix24
1 files changed, 24 insertions, 0 deletions
diff --git a/modules/personal.nix b/modules/personal.nix
new file mode 100644
index 0000000..97b3f03
--- /dev/null
+++ b/modules/personal.nix
@@ -0,0 +1,24 @@
+## Personal utils for daily use machines like laptop, cell phone
+## This should not be used on a server
+
+{ pkgs, ... }:
+{
+  programs.gnupg = {
+    agent = {
+      enable = true;
+      enableSSHSupport = true;
+      pinentryFlavor = "gnome3";
+    };
+  };
+
+  environment.systemPackages = with pkgs; [
+    pass ssh-ident
+  ];
+
+  programs.browserpass.enable = true;
+
+  environment.shellAliases = {
+    ssh = "ssh-ident";
+  };
+
+}