about summary refs log tree commit diff
path: root/machines/x220/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'machines/x220/hardware-configuration.nix')
-rwxr-xr-xmachines/x220/hardware-configuration.nix63
1 files changed, 0 insertions, 63 deletions
diff --git a/machines/x220/hardware-configuration.nix b/machines/x220/hardware-configuration.nix
deleted file mode 100755
index 4f7b908..0000000
--- a/machines/x220/hardware-configuration.nix
+++ /dev/null
@@ -1,63 +0,0 @@
-# ThinkPad X220
-
-# Do not modify this file!  It was generated by ‘nixos-generate-config’
-# and may be overwritten by future invocations.  Please make changes
-# to /etc/nixos/configuration.nix instead.
-{ config, lib, pkgs, ... }:
-
-{
-  imports =
-    [ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
-  ];
-
-  boot.initrd.availableKernelModules = [ "ehci_pci" "ahci" "usb_storage" "sd_mod" "sdhci_pci" ];
-  boot.initrd.kernelModules = [ ];
-  boot.kernelModules = [ "kvm-intel" "tp_smapi" "v4l2loopback" "acpi_call" ];
-  boot.extraModulePackages = with config.boot.kernelPackages; [ v4l2loopback tp_smapi acpi_call ];
-
-
-  boot.loader.grub.enable = true;
-  boot.loader.grub.version = 2;
-  boot.loader.grub.device = "/dev/sda"; # or "nodev" for efi only
-
-  boot.plymouth.enable = true;
-
-
-  fileSystems = {
-    "/" =
-      { device = "/dev/disk/by-uuid/e00c989b-b3fd-469e-b894-ea609fb4d7fa";
-      fsType = "ext4";
-    };
-
-    "/boot" =
-      { device = "/dev/disk/by-uuid/2f0948cd-a0de-41c0-a341-e9fe01460fd3";
-      fsType = "ext3";
-    };
-    "/home" = {
-      device = "/dev/disk/by-label/home";
-      fsType = "ext4";
-    };
-    "/nix" = {
-      device = "/dev/disk/by-label/nix";
-      fsType = "ext4";
-    };
-    "/var/lib/docker" = {
-      device = "/dev/disk/by-label/docker";
-      fsType = "ext4";
-    };
-    "/mnt/qnap" = {
-      device = "//192.168.1.119/Patryk";
-      fsType = "cifs";
-      options = let
-        # this line prevents hanging on network split
-        automount_opts = "x-systemd.automount,noauto,x-systemd.idle-timeout=60,x-systemd.device-timeout=5s,x-systemd.mount-timeout=5s,vers=1.0";
-
-      in ["${automount_opts},credentials=/etc/nixos/smb-secrets"];
-    };
-  };
-  swapDevices = [ {
-    device = "/dev/sda2"; } ];
-
-    nix.maxJobs = lib.mkDefault 4;
-    powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
-  }