about summary refs log tree commit diff
path: root/machines/x220/disko-config.nix
diff options
context:
space:
mode:
Diffstat (limited to 'machines/x220/disko-config.nix')
-rw-r--r--machines/x220/disko-config.nix48
1 files changed, 24 insertions, 24 deletions
diff --git a/machines/x220/disko-config.nix b/machines/x220/disko-config.nix
index cdf31bd..3512416 100644
--- a/machines/x220/disko-config.nix
+++ b/machines/x220/disko-config.nix
@@ -8,30 +8,30 @@
 { lib, config, ... }:
 {
 
-  boot.initrd.postDeviceCommands = ''
-    mkdir /btrfs_tmp
-    mount -t btrfs -o subvol=root,defaults ${config.disko.devices.disk.main.device} /btrfs_tmp
-    if [[ -e /btrfs_tmp/root ]]; then
-        mkdir -p /btrfs_tmp/old_roots
-        timestamp=$(date --date="@$(stat -c %Y /btrfs_tmp/root)" "+%Y-%m-%-d_%H:%M:%S")
-        mv /btrfs_tmp/root "/btrfs_tmp/old_roots/$timestamp"
-    fi
-
-    delete_subvolume_recursively() {
-        IFS=$'\n'
-        for i in $(btrfs subvolume list -o "$1" | cut -f 9- -d ' '); do
-            delete_subvolume_recursively "/btrfs_tmp/$i"
-        done
-        btrfs subvolume delete "$1"
-    }
-
-    for i in $(find /btrfs_tmp/old_roots/ -maxdepth 1 -mtime +30); do
-        delete_subvolume_recursively "$i"
-    done
-
-    btrfs subvolume create /btrfs_tmp/root
-    umount /btrfs_tmp
-  '';
+  #boot.initrd.postDeviceCommands = ''
+    #mkdir /btrfs_tmp
+    #mount -t btrfs -o subvol=root,defaults ${config.disko.devices.disk.main.device} /btrfs_tmp
+    #if [[ -e /btrfs_tmp/root ]]; then
+        #mkdir -p /btrfs_tmp/old_roots
+        #timestamp=$(date --date="@$(stat -c %Y /btrfs_tmp/root)" "+%Y-%m-%-d_%H:%M:%S")
+        #mv /btrfs_tmp/root "/btrfs_tmp/old_roots/$timestamp"
+    #fi
+#
+    #delete_subvolume_recursively() {
+        #IFS=$'\n'
+        #for i in $(btrfs subvolume list -o "$1" | cut -f 9- -d ' '); do
+            #delete_subvolume_recursively "/btrfs_tmp/$i"
+        #done
+        #btrfs subvolume delete "$1"
+    #}
+#
+    #for i in $(find /btrfs_tmp/old_roots/ -maxdepth 1 -mtime +30); do
+        #delete_subvolume_recursively "$i"
+    #done
+#
+    #btrfs subvolume create /btrfs_tmp/root
+    #umount /btrfs_tmp
+  #'';
 
   disko.devices = {
     disk = {