about summary refs log tree commit diff
path: root/machines/x220/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'machines/x220/configuration.nix')
-rw-r--r--machines/x220/configuration.nix24
1 files changed, 14 insertions, 10 deletions
diff --git a/machines/x220/configuration.nix b/machines/x220/configuration.nix
index c98548f..73c8a59 100644
--- a/machines/x220/configuration.nix
+++ b/machines/x220/configuration.nix
@@ -1,6 +1,7 @@
 { pkgs, lib, ... }:
 
 let
+  signal = pkgs.callPackage ../../pkgs/signal.nix { };
   busybox_utils = pkgs.stdenv.mkDerivation {
     name = "strings";
     unpackPhase = "true";
@@ -24,7 +25,7 @@ in
     ];
 
     boot.plymouth.enable = true;
-    boot.binfmt.emulatedSystems = [ "aarch64-linux" ];
+    # boot.binfmt.emulatedSystems = [ "aarch64-linux" ];
 
     networking = {
       hostName = "x220";
@@ -44,11 +45,19 @@ in
       show-trace = true
     '';
 
+    environment.variables = {
+      ELECTRUMDIR="$\{XDG_DATA_HOME:-$HOME/.local/share}/electrum";
+    };
+
+    environment.binsh = "${pkgs.dash}/bin/dash";
+
     environment.systemPackages = with pkgs; [
+      guvcview
+      signal
       usbutils
       discord
     # Basic tools
-    groff file ssh-ident busybox_utils
+    file ssh-ident busybox_utils
 
     # XORG perfs
     dunst
@@ -57,7 +66,7 @@ in
     zathura sxiv pulsemixer
     lynx lf arandr wpa_supplicant_gui
     system-config-printer libreoffice
-    vscodium abook
+    abook
 
     # Audio/Video
     mpd mpc_cli mpv ffmpeg youtube-dl
@@ -66,13 +75,10 @@ in
     gitAndTools.gh docker-compose xsel
     bc libnotify
     pamixer maim killall
-    quickserve ueberzug chafa
+    ueberzug chafa
 
     # Thinkpad utils
-    nur.repos.pn.dockd acpi tpacpi-bat
-
-    wineStaging
-
+    acpi tpacpi-bat
   ];
 
   fonts.fonts = with pkgs; [
@@ -90,8 +96,6 @@ in
   programs.browserpass.enable = true;
   programs.dockd.enable = true;
 
-  virtualisation.anbox.enable = true;
-  programs.adb.enable = true;
 
   virtualisation.docker.enable = true;
   systemd.services.docker.wantedBy = lib.mkForce [];