about summary refs log tree commit diff
path: root/machines/srv1/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'machines/srv1/hardware-configuration.nix')
-rw-r--r--machines/srv1/hardware-configuration.nix27
1 files changed, 27 insertions, 0 deletions
diff --git a/machines/srv1/hardware-configuration.nix b/machines/srv1/hardware-configuration.nix
new file mode 100644
index 0000000..3631a5d
--- /dev/null
+++ b/machines/srv1/hardware-configuration.nix
@@ -0,0 +1,27 @@
+# Do not modify this file!  It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations.  Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+  imports =
+    [ (modulesPath + "/installer/scan/not-detected.nix")
+    ];
+
+  boot.initrd.availableKernelModules = [ "uhci_hcd" "ehci_pci" "ata_piix" "usb_storage" "usbhid" "sd_mod" ];
+  boot.initrd.kernelModules = [ ];
+  boot.kernelModules = [ "dme1737" ];
+  boot.extraModulePackages = [ ];
+
+  fileSystems."/" =
+    { device = "/dev/disk/by-uuid/7daf3fc2-5800-47f8-a4fd-12a7229f727a";
+      fsType = "ext4";
+    };
+
+  swapDevices = [
+    {
+      device = "/swapfile"; size = 2048;
+    }
+  ];
+
+}