about summary refs log tree commit diff
path: root/machines/rpi3-amadeus/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'machines/rpi3-amadeus/configuration.nix')
-rw-r--r--machines/rpi3-amadeus/configuration.nix15
1 files changed, 13 insertions, 2 deletions
diff --git a/machines/rpi3-amadeus/configuration.nix b/machines/rpi3-amadeus/configuration.nix
index 3f2acc7..96e5f2f 100644
--- a/machines/rpi3-amadeus/configuration.nix
+++ b/machines/rpi3-amadeus/configuration.nix
@@ -1,5 +1,8 @@
 { config, pkgs, lib, ... }:
 {
+  imports = [
+    ./hyperion.nix
+  ];
   # NixOS wants to enable GRUB by default
   boot.loader.grub.enable = false;
   # Enables the generation of /boot/extlinux/extlinux.conf
@@ -16,17 +19,25 @@
 
   # File systems configuration for using the installer's partition layout
   fileSystems = {
-      "/" = {
+    "/" = {
       device = "/dev/disk/by-label/NIXOS_SD";
       fsType = "ext4";
     };
   };
 
-
   services.openssh.enable = true;
   services.openssh.permitRootLogin = "yes";
 
+  nix.gc.automatic = true;
+  nix.gc.options = "--delete-older-than 30d";
 
   # !!! Adding a swap file is optional, but strongly recommended!
   swapDevices = [ { device = "/swapfile"; size = 1024; } ];
+
+
+  users.users.pi = {
+    isNormalUser = true;
+    home = "/home/pi";
+    extraGroups = [ "wheel" "networkmanager" ];
+  };
 }