about summary refs log tree commit diff
path: root/machines/hp-compaq/hardware-configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'machines/hp-compaq/hardware-configuration.nix')
-rwxr-xr-xmachines/hp-compaq/hardware-configuration.nix7
1 files changed, 7 insertions, 0 deletions
diff --git a/machines/hp-compaq/hardware-configuration.nix b/machines/hp-compaq/hardware-configuration.nix
index a2f8180..6971c39 100755
--- a/machines/hp-compaq/hardware-configuration.nix
+++ b/machines/hp-compaq/hardware-configuration.nix
@@ -13,6 +13,13 @@
   boot.kernelModules = [ ];
   boot.extraModulePackages = [ ];
 
+  boot.loader.grub.enable = true;
+  boot.loader.grub.version = 2;
+  boot.loader.grub.device = "/dev/sda"; # or "nodev" for efi only
+
+  networking.useDHCP = false;
+  networking.interfaces.enp2s0.useDHCP = true;
+
   fileSystems."/" =
     { device = "/dev/disk/by-uuid/ad2775d5-5890-493e-b709-60c1f7f3c63b";
       fsType = "ext4";