about summary refs log tree commit diff
path: root/machines/hp-compaq/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'machines/hp-compaq/configuration.nix')
-rwxr-xr-xmachines/hp-compaq/configuration.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/machines/hp-compaq/configuration.nix b/machines/hp-compaq/configuration.nix
new file mode 100755
index 0000000..958088c
--- /dev/null
+++ b/machines/hp-compaq/configuration.nix
@@ -0,0 +1,22 @@
+{ config, pkgs, ... }:
+
+{
+  imports =
+    [ # Include the results of the hardware scan.
+      ./hardware-configuration.nix
+    ];
+
+  boot.loader.grub.enable = true;
+  boot.loader.grub.version = 2;
+  boot.loader.grub.device = "/dev/sda"; # or "nodev" for efi only
+
+  networking.hostName = "hp-compaq";
+
+  networking.useDHCP = false;
+  networking.interfaces.enp2s0.useDHCP = true;
+
+  environment.systemPackages = with pkgs; [
+  ];
+
+}
+