about summary refs log tree commit diff
path: root/machines/hp-compaq/configuration.nix
diff options
context:
space:
mode:
authorPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2020-12-11 12:11:45 +0100
committerPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2020-12-11 12:11:45 +0100
commit527c96af4ed48111cfa19161fb2680b6866c2594 (patch)
tree54fc683de97bb5a768598413cebae83553e4f7c1 /machines/hp-compaq/configuration.nix
parentbb668c1bdfb2937e2ca987426aac6cfe1b544fc9 (diff)
downloaddots-527c96af4ed48111cfa19161fb2680b6866c2594.tar.gz
dots-527c96af4ed48111cfa19161fb2680b6866c2594.zip
Add machines folder
Diffstat (limited to 'machines/hp-compaq/configuration.nix')
-rwxr-xr-xmachines/hp-compaq/configuration.nix22
1 files changed, 22 insertions, 0 deletions
diff --git a/machines/hp-compaq/configuration.nix b/machines/hp-compaq/configuration.nix
new file mode 100755
index 0000000..958088c
--- /dev/null
+++ b/machines/hp-compaq/configuration.nix
@@ -0,0 +1,22 @@
+{ config, pkgs, ... }:
+
+{
+  imports =
+    [ # Include the results of the hardware scan.
+      ./hardware-configuration.nix
+    ];
+
+  boot.loader.grub.enable = true;
+  boot.loader.grub.version = 2;
+  boot.loader.grub.device = "/dev/sda"; # or "nodev" for efi only
+
+  networking.hostName = "hp-compaq";
+
+  networking.useDHCP = false;
+  networking.interfaces.enp2s0.useDHCP = true;
+
+  environment.systemPackages = with pkgs; [
+  ];
+
+}
+