about summary refs log tree commit diff
path: root/machines/base.nix
diff options
context:
space:
mode:
Diffstat (limited to 'machines/base.nix')
-rwxr-xr-xmachines/base.nix3
1 files changed, 3 insertions, 0 deletions
diff --git a/machines/base.nix b/machines/base.nix
index 75935ec..e00ec97 100755
--- a/machines/base.nix
+++ b/machines/base.nix
@@ -37,6 +37,8 @@
 
   ## === XDG ===
   environment.variables = rec {
+    PATH = "$HOME/scripts:$PATH";
+
     XDG_CONFIG_HOME = "$HOME/.config";
     XDG_CACHE_HOME = "$HOME/.cache";
     XDG_DATA_HOME = "$HOME/.local/share";
@@ -79,6 +81,7 @@
     syntaxHighlighting.enable = true;
 
     promptInit = ''
+      [ "$(tty)" = "/dev/tty1" ] && startx
       any-nix-shell zsh --info-right | source /dev/stdin
       autoload -U colors && colors
       PS1="%B%{$fg[red]%}[%{$fg[yellow]%}%n%{$fg[green]%}@%{$fg[blue]%}%M %{$fg[magenta]%}%~%{$fg[red]%}]%{$reset_color%}$%b "