about summary refs log tree commit diff
path: root/machines/asus/configuration.nix
diff options
context:
space:
mode:
Diffstat (limited to 'machines/asus/configuration.nix')
-rwxr-xr-xmachines/asus/configuration.nix50
1 files changed, 0 insertions, 50 deletions
diff --git a/machines/asus/configuration.nix b/machines/asus/configuration.nix
deleted file mode 100755
index a64f9d2..0000000
--- a/machines/asus/configuration.nix
+++ /dev/null
@@ -1,50 +0,0 @@
-{ config, pkgs, ... }:
-let
-  screen-orient = pkgs.writeScriptBin "screen-orient" ''
-    #!${pkgs.stdenv.shell}
-    xrandr --output DSI1 --primary --mode 800x1280 --pos 0x0 --rotate left --output DP1 --off --output HDMI1 --off
-
-xinput set-prop "SIS0457:00 0457:113D" "Coordinate Transformation Matrix" 0 -1 1 1 0 0 0 0 1
-  '';
-in
-{
-
-  imports = [
-    ../base.nix
-    ../pl.nix
-    ../../modules/larbs.nix
-    ../../modules/trackpad.nix
-  ];
-
-  networking = {
-    hostName = "asus-t100";
-
-    networkmanager = {
-      enable = true;
-      wifi.backend = "iwd";
-    };
-  };
-
-
-  environment.systemPackages = with pkgs; [
-    libimobiledevice
-    screen-orient
-  ];
-
-  services.usbmuxd.enable = true;
-
-  services.acpid.enable = true;
-
-  # Battery
-  services.tlp.enable = true;
-
-  services.xserver = {
-    videoDrivers = [ "intel" ];
-    deviceSection = ''
-      Option "Backlight" "intel_backlight"
-      Option "DIR" "2"
-      Option "TearFree" "true"
-    '';
-  };
-
-}