about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix42
1 files changed, 29 insertions, 13 deletions
diff --git a/flake.nix b/flake.nix
index 5053df8..6a1b9f8 100644
--- a/flake.nix
+++ b/flake.nix
@@ -11,19 +11,35 @@
 	};
 
 	outputs = { self, nixpkgs, ... }@inputs: {
-		nixosConfigurations.nixos = nixpkgs.lib.nixosSystem {
-			specialArgs = {inherit inputs;};
-			modules = [
-				./machines/t14/configuration.nix
-
-					inputs.home-manager.nixosModules.default
-					{
-						home-manager.useGlobalPkgs = true;
-						home-manager.useUserPackages = true;
-						home-manager.users.pn = import ./home.nix;
-					}
-
-			];
+		nixosConfigurations = {
+			nixos = nixpkgs.lib.nixosSystem {
+				specialArgs = {inherit inputs;};
+				modules = [
+					./machines/x220-gnome/configuration.nix
+	
+						inputs.home-manager.nixosModules.default
+						{
+							home-manager.useGlobalPkgs = true;
+							home-manager.useUserPackages = true;
+							home-manager.users.pn = import ./home.nix;
+						}
+	
+				];
+			};
+			t14 = nixpkgs.lib.nixosSystem {
+				specialArgs = {inherit inputs;};
+				modules = [
+					./machines/t14/configuration.nix
+	
+						inputs.home-manager.nixosModules.default
+						{
+							home-manager.useGlobalPkgs = true;
+							home-manager.useUserPackages = true;
+							home-manager.users.pn = import ./home.nix;
+						}
+	
+				];
+			};
 		};
 	};
 }