about summary refs log tree commit diff
path: root/flake.nix
diff options
context:
space:
mode:
Diffstat (limited to 'flake.nix')
-rw-r--r--flake.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/flake.nix b/flake.nix
new file mode 100644
index 0000000..6f92c24
--- /dev/null
+++ b/flake.nix
@@ -0,0 +1,28 @@
+{
+	description = "Nixos config flake";
+
+	inputs = {
+		nixpkgs.url = "github:nixos/nixpkgs/nixos-24.05";
+
+		home-manager = {
+			url = "github:nix-community/home-manager";
+			inputs.nixpkgs.follows = "nixpkgs";
+		};
+	};
+
+	outputs = { self, nixpkgs, ... }@inputs: {
+		nixosConfigurations.nixos = nixpkgs.lib.nixosSystem {
+			specialArgs = {inherit inputs;};
+			modules = [
+				./machines/x220-gnome/configuration.nix
+					inputs.home-manager.nixosModules.default
+					{
+						home-manager.useGlobalPkgs = true;
+						home-manager.useUserPackages = true;
+						home-manager.users.pn = import ./home.nix;
+					}
+
+			];
+		};
+	};
+}