about summary refs log tree commit diff
path: root/users/pn.nix
diff options
context:
space:
mode:
authorPatryk Niedzwiedzinski <patryk@niedzwiedzinski.cyou>2024-09-29 18:22:10 +0200
committerPatryk Niedzwiedzinski <patryk@niedzwiedzinski.cyou>2024-09-29 18:22:10 +0200
commit110720bae4584f4d7d091a2fbff2f58897ba8bce (patch)
treeb9f59efe25f9a62a651682c745686bb76ecf4290 /users/pn.nix
parent57b6219ea9756cdf0d81e6768577bebf884dae28 (diff)
downloaddots-110720bae4584f4d7d091a2fbff2f58897ba8bce.tar.gz
dots-110720bae4584f4d7d091a2fbff2f58897ba8bce.zip
Remove users and neovim
Diffstat (limited to 'users/pn.nix')
-rwxr-xr-xusers/pn.nix66
1 files changed, 0 insertions, 66 deletions
diff --git a/users/pn.nix b/users/pn.nix
deleted file mode 100755
index 7a01354..0000000
--- a/users/pn.nix
+++ /dev/null
@@ -1,66 +0,0 @@
-## My default user
-{ pkgs, ... }:
-
-let
-  home-manager = builtins.fetchTarball {
-    url = "https://github.com/nix-community/home-manager/archive/63f299b3347aea183fc5088e4d6c4a193b334a41.tar.gz";
-    sha256 = "0iksjch94wfvyq0cgwv5wq52j0dc9cavm68wka3pahhdvjlxd3js";
-  };
-in
-  {
-
-    imports = [
-      (import "${home-manager}/nixos")
-    ];
-
-    nix.trustedUsers = [ "pn" ];
-
-    users.users.pn = {
-      isNormalUser = true;
-      extraGroups = [ "wheel" "video" "audio" ];
-    };
-
-    environment.systemPackages = [ pkgs.picom ];
-
-    home-manager.users.pn = {
-      imports = [
-        ../home.nix
-        ../platforms/linux/user-dirs.nix
-        ../platforms/linux/gtk.nix
-      ];
-
-      gtk.enable = true;
-
-      xsession = {
-        enable = true;
-        windowManager.command = "dbus-run-session -- dwm";
-        profileExtra = ''
-      # Fix Gnome Apps Slow  Start due to failing services
-      # Add this when you include flatpak in your system
-          dbus-update-activation-environment --systemd DBUS_SESSION_BUS_ADDRESS DISPLAY XAUTHORITY
-
-          mpd &			# music player daemon-you might prefer it as a service though
-          remaps &		# run the remaps script, switching caps/esc and more; check it for more info
-          setbg &			# set the background with the `setbg` script
-          xrdb $HOME/.config/Xresources &	# Uncomment to use Xresources colors/settings on startup
-          #xcompmgr &
-          picom &
-          dunst &			# dunst for notifications
-          xset r rate 300 50 &	# Speed xrate up
-      # unclutter &		# Remove mouse when idle
-      #sxhkd &
-          dockd --daemon &
-          for app in `ls ~/.config/autostart/*.desktop`; do
-          $(grep '^Exec' $app | sed 's/^Exec=//') &
-          done
-          sleep .5 && screen-orient &
-          duckling-proxy --serverCert $HOME/.config/duckling-proxy/ca.crt --serverKey $HOME/.config/duckling-proxy/ca.key &
-        '';
-        scriptPath = ".xinitrc";
-      };
-
-    };
-
-  ## Although it's less secure I tend not to have sensitive data on my machines
-  security.sudo.wheelNeedsPassword = false;
-}