about summary refs log tree commit diff
path: root/programs/nvim.nix
diff options
context:
space:
mode:
authorPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2020-11-22 10:53:48 +0100
committerPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2020-11-22 10:53:48 +0100
commitb3bd9ff5c9ad4cb7c785f5a56ce4d3f3208e23d7 (patch)
tree956a70f735d8c261580289fdd378435fac22ed40 /programs/nvim.nix
parent9f4077d3579b9837fff78b8f36661c7abc41cd10 (diff)
downloaddots-b3bd9ff5c9ad4cb7c785f5a56ce4d3f3208e23d7.tar.gz
dots-b3bd9ff5c9ad4cb7c785f5a56ce4d3f3208e23d7.zip
Update
Diffstat (limited to 'programs/nvim.nix')
-rw-r--r--programs/nvim.nix6
1 files changed, 2 insertions, 4 deletions
diff --git a/programs/nvim.nix b/programs/nvim.nix
index d903c4d..6ce3e7b 100644
--- a/programs/nvim.nix
+++ b/programs/nvim.nix
@@ -108,11 +108,9 @@ pkgs.neovim.override {
         autocmd BufWritepre * %s/\n\+\%$//e
 
       " When shortcut files are updated, renew bash and ranger configs with new material:
-        autocmd BufWritePost files,directories !shortcuts
+        autocmd BufWritePost bm-files,bm-dirs !shortcuts
       " Run xrdb whenever Xdefaults or Xresources are updated.
-        autocmd BufWritePost *Xresources,*Xdefaults !xrdb %
-      " Update binds when sxhkdrc is updated.
-        autocmd BufWritePost *sxhkdrc !pkill -USR1 sxhkd
+        autocmd BufWritePost *Xresources,*Xdefaults,*xresources,*xdefaults !xrdb %
 
       " Turns off highlighting on the bits of code that are changed, so the line that is changed is highlighted but the actual text that has changed stands out on the line and is readable.
       if &diff