about summary refs log tree commit diff
path: root/modules/internet.nix
diff options
context:
space:
mode:
authorPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2021-03-08 19:23:49 +0100
committerPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2021-03-08 19:23:49 +0100
commit781baa6ff78ed10649914fc8311f84a4b8af80bd (patch)
tree746a331f20c07a108e5bbf5299f547752e62ca63 /modules/internet.nix
parentf3688102bd5c7756fbb4bd3f18811630a8791254 (diff)
parent8606a412bb6137fa4917e4bab57ab65e7549e94d (diff)
downloaddots-781baa6ff78ed10649914fc8311f84a4b8af80bd.tar.gz
dots-781baa6ff78ed10649914fc8311f84a4b8af80bd.zip
Merge branch 'master' of https://github.com/pniedzwiedzinski/dots
Diffstat (limited to 'modules/internet.nix')
-rw-r--r--modules/internet.nix22
1 files changed, 15 insertions, 7 deletions
diff --git a/modules/internet.nix b/modules/internet.nix
index dedc269..bb0e554 100644
--- a/modules/internet.nix
+++ b/modules/internet.nix
@@ -1,15 +1,23 @@
 ## Basic rules for interacting with the internet
-{ pkgs, ... }:
+{ pkgs, lib, ... }:
 {
-  networking.nameservers = [
-    "1.1.1.1"
-    "8.8.8.8"
-  ];
+  # networking.nameservers = lib.mkForce [
+  #   "192.168.1.136"
+  #   "1.1.1.1"
+  #   "8.8.8.8"
+  # ];
+
+  environment.etc."resolv.conf".text = ''
+    nameserver 192.168.1.136
+    nameserver 1.1.1.1
+    nameserver 8.8.8.8
+    options edns0
+  '';
 
 
   networking.extraHosts = pkgs.stdenv.lib.readFile ( pkgs.fetchurl {
-    url = "https://raw.githubusercontent.com/StevenBlack/hosts/5a5016ab5bf0166e004147cb49ccd0114ed29b72/alternates/fakenews-gambling-porn/hosts";
-    sha256 = "1c60fyzxz89bic6ymcvb8fcanyxpzr8v2z5vixxr79d8mj0vjswm";
+    url = "https://raw.githubusercontent.com/StevenBlack/hosts/d2be343994aacdec74865ff8d159cf6e46359adf/alternates/fakenews-gambling-porn/hosts";
+    sha256 = "1la5rd0znc25q8yd1iwbx22zzqi6941vyzmgar32jx568j856s8j";
   } );
 
 }