about summary refs log tree commit diff
path: root/modules/gnome.nix
diff options
context:
space:
mode:
authorPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2024-09-29 19:58:54 +0200
committerPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2024-09-29 19:58:54 +0200
commit338fa6d7bf4cbe22cf9bf704f637ec7d4e1b786b (patch)
tree42452c16659f706fc2ab15fc1af71b18fbd1fd77 /modules/gnome.nix
parent66f919b2e169643eb3fd51b7229d80cf9a413b44 (diff)
downloaddots-338fa6d7bf4cbe22cf9bf704f637ec7d4e1b786b.tar.gz
dots-338fa6d7bf4cbe22cf9bf704f637ec7d4e1b786b.zip
t14: 29 current 2024-09-29 19:58:51 24.05.20240928.fbca5e7 6.6.52 *
Diffstat (limited to 'modules/gnome.nix')
-rw-r--r--modules/gnome.nix9
1 files changed, 9 insertions, 0 deletions
diff --git a/modules/gnome.nix b/modules/gnome.nix
index 6d8bb29..219b623 100644
--- a/modules/gnome.nix
+++ b/modules/gnome.nix
@@ -1,4 +1,7 @@
 { pkgs, ... }:
+let
+	switch-theme = pkgs.writeShellScriptBin "switch-theme" (builtins.readFile ./switch-theme.sh);
+in
 {
 # Enable the X11 windowing system.
 	services.xserver.enable = true;
@@ -43,7 +46,12 @@
               					binding = "<Super>Return";
               					command = "kgx";
               					name = "GNOME Console";
+            				};
 
+					"org/gnome/settings-daemon/plugins/media-keys/custom-keybindings/custom1" = {
+              					binding = "<TaskPane>";
+              					command = "switch-theme";
+              					name = "Switch Theme";
             				};
 
 				};
@@ -83,6 +91,7 @@
 	boot.plymouth.enable = true;
 
 	environment.systemPackages = with pkgs; [
+		switch-theme
 		libnotify
 		gnome.gnome-boxes
 		gnome.file-roller