about summary refs log tree commit diff
path: root/machines/x220/hardware-configuration.nix
diff options
context:
space:
mode:
authorPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2020-12-23 23:07:54 +0100
committerPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2020-12-23 23:07:54 +0100
commitbcf66d4c083015a109a3e1b4d6c37dc67ef0cf33 (patch)
treeadb622811dacd1da8534f763f65a2d939c01ddb4 /machines/x220/hardware-configuration.nix
parent9a5439c21c565115d8a6a659ab8274be2c797c10 (diff)
downloaddots-bcf66d4c083015a109a3e1b4d6c37dc67ef0cf33.tar.gz
dots-bcf66d4c083015a109a3e1b4d6c37dc67ef0cf33.zip
Fix build on x220 @20.09
Diffstat (limited to 'machines/x220/hardware-configuration.nix')
-rwxr-xr-xmachines/x220/hardware-configuration.nix35
1 files changed, 24 insertions, 11 deletions
diff --git a/machines/x220/hardware-configuration.nix b/machines/x220/hardware-configuration.nix
index 935e986..c9d9e1d 100755
--- a/machines/x220/hardware-configuration.nix
+++ b/machines/x220/hardware-configuration.nix
@@ -8,7 +8,7 @@
 {
   imports =
     [ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
-    ];
+  ];
 
   boot.initrd.availableKernelModules = [ "ehci_pci" "ahci" "usb_storage" "sd_mod" "sdhci_pci" ];
   boot.initrd.kernelModules = [ ];
@@ -23,19 +23,32 @@
   boot.plymouth.enable = true;
 
 
-  fileSystems."/" =
-    { device = "/dev/disk/by-uuid/e00c989b-b3fd-469e-b894-ea609fb4d7fa";
+  fileSystems = {
+    "/" =
+      { device = "/dev/disk/by-uuid/e00c989b-b3fd-469e-b894-ea609fb4d7fa";
       fsType = "ext4";
     };
 
-  fileSystems."/boot" =
-    { device = "/dev/disk/by-uuid/2f0948cd-a0de-41c0-a341-e9fe01460fd3";
+    "/boot" =
+      { device = "/dev/disk/by-uuid/2f0948cd-a0de-41c0-a341-e9fe01460fd3";
       fsType = "ext3";
     };
+    "/home" = {
+      device = "/dev/disk/by-label/home";
+      fsType = "ext4";
+    };
+    "/nix" = {
+      device = "/dev/disk/by-label/nix";
+      fsType = "ext4";
+    };
+    "/var/lib/docker" = {
+      device = "/dev/disk/by-label/docker";
+      fsType = "ext4";
+    };
+  };
+  swapDevices = [ {
+    device = "/dev/sda2"; } ];
 
-    swapDevices = [ {
-      device = "/dev/sda2"; } ];
-
-  nix.maxJobs = lib.mkDefault 4;
-  powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
-}
+    nix.maxJobs = lib.mkDefault 4;
+    powerManagement.cpuFreqGovernor = lib.mkDefault "powersave";
+  }