about summary refs log tree commit diff
path: root/machines/x220/configuration.nix
diff options
context:
space:
mode:
authorPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2021-04-11 10:25:05 +0200
committerPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2021-04-11 10:25:05 +0200
commit167733884d9e80b56ce168d45c08404bc4aabe5b (patch)
tree26eed373c1064056c19822ee48a5dd4d24d771bc /machines/x220/configuration.nix
parent22acd4632390bf1231bc7e234fbb6361bbb61368 (diff)
downloaddots-167733884d9e80b56ce168d45c08404bc4aabe5b.tar.gz
dots-167733884d9e80b56ce168d45c08404bc4aabe5b.zip
Remove obsolete settings
Diffstat (limited to 'machines/x220/configuration.nix')
-rw-r--r--machines/x220/configuration.nix23
1 files changed, 13 insertions, 10 deletions
diff --git a/machines/x220/configuration.nix b/machines/x220/configuration.nix
index 56d1d2f..73c8a59 100644
--- a/machines/x220/configuration.nix
+++ b/machines/x220/configuration.nix
@@ -25,7 +25,7 @@ in
     ];
 
     boot.plymouth.enable = true;
-    boot.binfmt.emulatedSystems = [ "aarch64-linux" ];
+    # boot.binfmt.emulatedSystems = [ "aarch64-linux" ];
 
     networking = {
       hostName = "x220";
@@ -45,11 +45,19 @@ in
       show-trace = true
     '';
 
+    environment.variables = {
+      ELECTRUMDIR="$\{XDG_DATA_HOME:-$HOME/.local/share}/electrum";
+    };
+
+    environment.binsh = "${pkgs.dash}/bin/dash";
+
     environment.systemPackages = with pkgs; [
+      guvcview
+      signal
       usbutils
       discord
     # Basic tools
-    groff file ssh-ident busybox_utils
+    file ssh-ident busybox_utils
 
     # XORG perfs
     dunst
@@ -58,7 +66,7 @@ in
     zathura sxiv pulsemixer
     lynx lf arandr wpa_supplicant_gui
     system-config-printer libreoffice
-    vscodium abook
+    abook
 
     # Audio/Video
     mpd mpc_cli mpv ffmpeg youtube-dl
@@ -67,13 +75,10 @@ in
     gitAndTools.gh docker-compose xsel
     bc libnotify
     pamixer maim killall
-    quickserve ueberzug chafa
+    ueberzug chafa
 
     # Thinkpad utils
-    nur.repos.pn.dockd acpi tpacpi-bat
-
-    wineStaging
-
+    acpi tpacpi-bat
   ];
 
   fonts.fonts = with pkgs; [
@@ -91,8 +96,6 @@ in
   programs.browserpass.enable = true;
   programs.dockd.enable = true;
 
-  virtualisation.anbox.enable = true;
-  programs.adb.enable = true;
 
   virtualisation.docker.enable = true;
   systemd.services.docker.wantedBy = lib.mkForce [];