about summary refs log tree commit diff
path: root/machines/x220-gnome/hardware-configuration.nix
diff options
context:
space:
mode:
authorPatryk Niedźwiedziński <patryk@niedzwiedzinski.cyou>2024-06-30 10:00:23 +0200
committerPatryk Niedźwiedziński <patryk@niedzwiedzinski.cyou>2024-06-30 10:00:23 +0200
commit616a0def587cb9243bd6b08cb96549870f1612da (patch)
treecac0a8b4d072fbd9973686664e40e3688995d12c /machines/x220-gnome/hardware-configuration.nix
parent501e7feaef8d8b93a507193b1ea1ab97a899de21 (diff)
downloaddots-616a0def587cb9243bd6b08cb96549870f1612da.tar.gz
dots-616a0def587cb9243bd6b08cb96549870f1612da.zip
Init x220-gnome
Diffstat (limited to 'machines/x220-gnome/hardware-configuration.nix')
-rw-r--r--machines/x220-gnome/hardware-configuration.nix51
1 files changed, 51 insertions, 0 deletions
diff --git a/machines/x220-gnome/hardware-configuration.nix b/machines/x220-gnome/hardware-configuration.nix
new file mode 100644
index 0000000..7db32ec
--- /dev/null
+++ b/machines/x220-gnome/hardware-configuration.nix
@@ -0,0 +1,51 @@
+# Do not modify this file!  It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations.  Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, modulesPath, ... }:
+
+{
+  imports =
+    [ (modulesPath + "/installer/scan/not-detected.nix")
+    ];
+
+  boot.loader.systemd-boot.enable = true;
+  boot.loader.efi.canTouchEfiVariables = true;
+
+  boot.initrd.luks.devices."luks-9f3a316a-7177-4122-a4f5-03fbd375d6e1".device = "/dev/disk/by-uuid/9f3a316a-7177-4122-a4f5-03fbd375d6e1";
+  networking.hostName = "nixos"; # Define your hostname.
+ 
+
+  boot.initrd.availableKernelModules = [ "ehci_pci" "ahci" "usb_storage" "sd_mod" "sdhci_pci" ];
+  boot.initrd.kernelModules = [ ];
+  boot.kernelModules = [ "kvm-intel" ];
+  boot.extraModulePackages = [ ];
+
+  fileSystems."/" =
+    { device = "/dev/disk/by-uuid/01db2679-e134-4870-b503-a0e616432175";
+      fsType = "ext4";
+    };
+
+  boot.initrd.luks.devices."luks-8a50e0b7-d2a7-4b0c-b092-9194536cae41".device = "/dev/disk/by-uuid/8a50e0b7-d2a7-4b0c-b092-9194536cae41";
+
+  fileSystems."/boot" =
+    { device = "/dev/disk/by-uuid/D259-64AC";
+      fsType = "vfat";
+      options = [ "fmask=0022" "dmask=0022" ];
+    };
+
+  swapDevices =
+    [ { device = "/dev/disk/by-uuid/a7366f52-418f-47a7-bb29-fbd394d559ee"; }
+    ];
+
+  # Enables DHCP on each ethernet and wireless interface. In case of scripted networking
+  # (the default) this is the recommended approach. When using systemd-networkd it's
+  # still possible to use this option, but it's recommended to use it in conjunction
+  # with explicit per-interface declarations with `networking.interfaces.<interface>.useDHCP`.
+  networking.useDHCP = lib.mkDefault true;
+  # networking.interfaces.enp0s25.useDHCP = lib.mkDefault true;
+  # networking.interfaces.wlp3s0.useDHCP = lib.mkDefault true;
+  # networking.interfaces.wwp0s29u1u4i6.useDHCP = lib.mkDefault true;
+
+  nixpkgs.hostPlatform = lib.mkDefault "x86_64-linux";
+  hardware.cpu.intel.updateMicrocode = lib.mkDefault config.hardware.enableRedistributableFirmware;
+}