about summary refs log tree commit diff
path: root/machines/srv3/webdav.nix
diff options
context:
space:
mode:
authorPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2024-10-30 19:28:28 +0100
committerPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2024-10-30 19:28:28 +0100
commit9c14b06fc484e4be8852c4f379cb1671ed367d6a (patch)
treeac54591e1ee05ee57c69627630bb80ff6ed24eb2 /machines/srv3/webdav.nix
parenta0b92062d9e3049b96ed9f64b35f71ed3064e163 (diff)
parentb813c1f7aa010862607558d70e6275bbdd111412 (diff)
downloaddots-9c14b06fc484e4be8852c4f379cb1671ed367d6a.tar.gz
dots-9c14b06fc484e4be8852c4f379cb1671ed367d6a.zip
Merge branch 'master' of github.com:pniedzwiedzinski/dots
Diffstat (limited to 'machines/srv3/webdav.nix')
-rw-r--r--machines/srv3/webdav.nix33
1 files changed, 33 insertions, 0 deletions
diff --git a/machines/srv3/webdav.nix b/machines/srv3/webdav.nix
new file mode 100644
index 0000000..9a4c126
--- /dev/null
+++ b/machines/srv3/webdav.nix
@@ -0,0 +1,33 @@
+{ pkgs, ... }:
+let
+	port = "6060";
+in
+{
+	services.nginx.virtualHosts."files.niedzwiedzinski.cyou" = {
+		forceSSL = true;
+		enableACME = true;
+
+		locations."/" = {
+			proxyPass = "http://localhost:${port}";
+		};
+	};
+
+	services.webdav = {
+		enable = true;
+		configFile = "/etc/webdav.yaml";
+		#settings = {
+			#address = "0.0.0.0";
+			#port = port;
+			#scope = "/srv/files";
+			#modify = true;
+			#auth = true;
+			#users = [
+			#{
+				#username = "patryk";
+				#password = "test";
+			#}
+			#];
+		#};
+	};
+
+}