about summary refs log tree commit diff
path: root/machines/rpi3-amadeus/hyperion.nix
diff options
context:
space:
mode:
authorPatryk Niedzwiedzinski <patryk@niedzwiedzinski.cyou>2024-09-29 16:23:16 +0200
committerPatryk Niedzwiedzinski <patryk@niedzwiedzinski.cyou>2024-09-29 16:23:16 +0200
commit4f591cc9c9663c413e8eb5cd8401a34a3251e30c (patch)
treedc46f698af4d5ba288e9e6707c2bc960e913bdd8 /machines/rpi3-amadeus/hyperion.nix
parent4fa1a6efad786affb0729603de846d2034580db2 (diff)
downloaddots-4f591cc9c9663c413e8eb5cd8401a34a3251e30c.tar.gz
dots-4f591cc9c9663c413e8eb5cd8401a34a3251e30c.zip
Remove old machines
Diffstat (limited to 'machines/rpi3-amadeus/hyperion.nix')
-rw-r--r--machines/rpi3-amadeus/hyperion.nix36
1 files changed, 0 insertions, 36 deletions
diff --git a/machines/rpi3-amadeus/hyperion.nix b/machines/rpi3-amadeus/hyperion.nix
deleted file mode 100644
index 094be80..0000000
--- a/machines/rpi3-amadeus/hyperion.nix
+++ /dev/null
@@ -1,36 +0,0 @@
-{ pkgs, ... }:
-let
-  hyperion = pkgs.callPackage ./hyperion-ng.nix { };
-  hyperionConfig = pkgs.fetchurl {
-    url = "https://gist.githubusercontent.com/pniedzwiedzinski/e1810bc4dd08b97512d28c42daa95326/raw/460febec24390dc90d3b70987f07ef1ab8a77b3a/hyperion.config.json";
-    sha256 = "1yaiw8ljy6kaq6vnf5ccq2c4wpjlakd00nmq51v1q2sdnc06jmqq";
-  };
-in
-{
-  imports = [
-    ./spi.nix
-  ];
-
-  environment.systemPackages = [
-    hyperion
-  ];
-
-
-  # networking.firewall.allowedTCPPorts = [  ];
-  networking.firewall.enable = false; #TODO
-
-  systemd.services.hyperion = {
-    enable = true;
-    wantedBy = ["multi-user.target"];
-    serviceConfig = {
-      ExecStart = "${hyperion}/bin/hyperiond";
-      ExecReload = "${pkgs.coreutils}/bin/kill -HUP $MAINPID";
-      Restart = "on-failure";
-      User = "root";
-      Group = "root";
-      Type = "simple";
-      UMask = "007";
-      TimeoutStopSec = "10";
-    };
-  };
-}