about summary refs log tree commit diff
path: root/machines/rpi3-amadeus/configuration.nix
diff options
context:
space:
mode:
authorPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2021-03-02 10:41:56 +0100
committerPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2021-03-02 10:41:56 +0100
commit1158b05b49fc0c79d5c90a9947d80d00ef885e10 (patch)
tree96bf50dc80f39dcde55a34583dff2fd5522c5ef3 /machines/rpi3-amadeus/configuration.nix
parentc4d8b4fd397752d23d3756fc58547b21a0daef0e (diff)
parentadb0c8cce1aa82eb88ccebccb1f635d4894a8822 (diff)
downloaddots-1158b05b49fc0c79d5c90a9947d80d00ef885e10.tar.gz
dots-1158b05b49fc0c79d5c90a9947d80d00ef885e10.zip
Merge branch 'master' of https://github.com/pniedzwiedzinski/dots
Diffstat (limited to 'machines/rpi3-amadeus/configuration.nix')
-rw-r--r--machines/rpi3-amadeus/configuration.nix20
1 files changed, 19 insertions, 1 deletions
diff --git a/machines/rpi3-amadeus/configuration.nix b/machines/rpi3-amadeus/configuration.nix
index 5a715f6..ba9ff57 100644
--- a/machines/rpi3-amadeus/configuration.nix
+++ b/machines/rpi3-amadeus/configuration.nix
@@ -5,6 +5,14 @@
   ];
   # NixOS wants to enable GRUB by default
   boot.loader.grub.enable = false;
+  boot.loader.raspberryPi = {
+    enable = true;
+    version = 3;
+    uboot.enable = true;
+    firmwareConfig = ''
+      gpu_mem=256
+    '';
+  };
   # Enables the generation of /boot/extlinux/extlinux.conf
   boot.loader.generic-extlinux-compatible.enable = true;
 
@@ -17,6 +25,9 @@
   # On a Raspberry Pi 4 with 4 GB, you should either disable this parameter or increase to at least 64M if you want the USB ports to work.
   boot.kernelParams = ["cma=32M"];
 
+  hardware.enableRedistributableFirmware = true;
+  hardware.firmware = with pkgs; [ raspberrypifw ];
+
   # File systems configuration for using the installer's partition layout
   fileSystems = {
     "/" = {
@@ -35,7 +46,8 @@
   swapDevices = [ { device = "/swapfile"; size = 1024; } ];
 
   environment.systemPackages = with pkgs; [
-    vim git curl wget usbutils
+    vim git curl wget
+    libraspberrypi
   ];
 
   users.users.pi = {
@@ -43,4 +55,10 @@
     home = "/home/pi";
     extraGroups = [ "wheel" "networkmanager" ];
   };
+  services.xserver = {
+    enable = true;
+    displayManager.startx.enable = true;
+    libinput.enable = true;
+  };
+
 }