about summary refs log tree commit diff
path: root/machines/hp-compaq/hardware-configuration.nix
diff options
context:
space:
mode:
authorPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2020-12-11 12:11:45 +0100
committerPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2020-12-11 12:11:45 +0100
commit527c96af4ed48111cfa19161fb2680b6866c2594 (patch)
tree54fc683de97bb5a768598413cebae83553e4f7c1 /machines/hp-compaq/hardware-configuration.nix
parentbb668c1bdfb2937e2ca987426aac6cfe1b544fc9 (diff)
downloaddots-527c96af4ed48111cfa19161fb2680b6866c2594.tar.gz
dots-527c96af4ed48111cfa19161fb2680b6866c2594.zip
Add machines folder
Diffstat (limited to 'machines/hp-compaq/hardware-configuration.nix')
-rwxr-xr-xmachines/hp-compaq/hardware-configuration.nix37
1 files changed, 37 insertions, 0 deletions
diff --git a/machines/hp-compaq/hardware-configuration.nix b/machines/hp-compaq/hardware-configuration.nix
new file mode 100755
index 0000000..a2f8180
--- /dev/null
+++ b/machines/hp-compaq/hardware-configuration.nix
@@ -0,0 +1,37 @@
+# Do not modify this file!  It was generated by ‘nixos-generate-config’
+# and may be overwritten by future invocations.  Please make changes
+# to /etc/nixos/configuration.nix instead.
+{ config, lib, pkgs, ... }:
+
+{
+  imports =
+    [ <nixpkgs/nixos/modules/installer/scan/not-detected.nix>
+    ];
+
+  boot.initrd.availableKernelModules = [ "uhci_hcd" "ehci_pci" "ata_piix" "usb_storage" "usbhid" "sd_mod" "sr_mod" ];
+  boot.initrd.kernelModules = [ ];
+  boot.kernelModules = [ ];
+  boot.extraModulePackages = [ ];
+
+  fileSystems."/" =
+    { device = "/dev/disk/by-uuid/ad2775d5-5890-493e-b709-60c1f7f3c63b";
+      fsType = "ext4";
+    };
+
+  fileSystems."/nix/store" =
+    { device = "/nix/store";
+      fsType = "none";
+      options = [ "bind" ];
+    };
+
+  fileSystems."/boot" =
+    { device = "/dev/disk/by-uuid/C6DC-F51D";
+      fsType = "vfat";
+    };
+
+  swapDevices =
+    [ { device = "/dev/disk/by-uuid/ad2b96eb-341c-40e2-bb86-1ed2f03a0713"; }
+    ];
+
+  nix.maxJobs = lib.mkDefault 2;
+}