about summary refs log tree commit diff
path: root/machines/base.nix
diff options
context:
space:
mode:
authorPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2021-05-01 16:37:38 +0200
committerPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2021-05-01 16:37:38 +0200
commit4277ed0f32c31db5267c173ccb45435fe8ae1667 (patch)
tree7d73974c971056b596a147cd8f9b13e8f8e2b359 /machines/base.nix
parent27b2750a12eba62a9e1e48081421ea585c05954b (diff)
parent052b9c4404a2678729712092dfdbb3e2ae25997b (diff)
downloaddots-4277ed0f32c31db5267c173ccb45435fe8ae1667.tar.gz
dots-4277ed0f32c31db5267c173ccb45435fe8ae1667.zip
Merge branch 'master' of https://github.com/pniedzwiedzinski/dots
Diffstat (limited to 'machines/base.nix')
-rwxr-xr-xmachines/base.nix5
1 files changed, 4 insertions, 1 deletions
diff --git a/machines/base.nix b/machines/base.nix
index 75935ec..035ee59 100755
--- a/machines/base.nix
+++ b/machines/base.nix
@@ -16,7 +16,7 @@
     wget vim curl htop file
     stdenv git zip unzip
     dnsutils ripgrep jq
-    any-nix-shell
+    any-nix-shell fd
   ];
 
   console.font = "${pkgs.terminus_font}/share/consolefonts/ter-v22n";
@@ -37,6 +37,8 @@
 
   ## === XDG ===
   environment.variables = rec {
+    PATH = "$HOME/scripts:$PATH";
+
     XDG_CONFIG_HOME = "$HOME/.config";
     XDG_CACHE_HOME = "$HOME/.cache";
     XDG_DATA_HOME = "$HOME/.local/share";
@@ -79,6 +81,7 @@
     syntaxHighlighting.enable = true;
 
     promptInit = ''
+      [ "$(tty)" = "/dev/tty1" ] && startx
       any-nix-shell zsh --info-right | source /dev/stdin
       autoload -U colors && colors
       PS1="%B%{$fg[red]%}[%{$fg[yellow]%}%n%{$fg[green]%}@%{$fg[blue]%}%M %{$fg[magenta]%}%~%{$fg[red]%}]%{$reset_color%}$%b "