about summary refs log tree commit diff
path: root/machines/asus/hardware-configuration.nix
diff options
context:
space:
mode:
authorPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2021-01-22 00:21:27 +0100
committerPatryk Niedźwiedziński <pniedzwiedzinski19@gmail.com>2021-01-22 00:21:27 +0100
commit0c5f6c91ea6b1c03a8eb4fd23a68655a1f2c8de5 (patch)
tree0744ae974e84e288c4b9ed5c63c5d875b2805e99 /machines/asus/hardware-configuration.nix
parentee8378fb4a312d1adc6d5293948dc44595f47c53 (diff)
downloaddots-0c5f6c91ea6b1c03a8eb4fd23a68655a1f2c8de5.tar.gz
dots-0c5f6c91ea6b1c03a8eb4fd23a68655a1f2c8de5.zip
Update acpi_override
Diffstat (limited to 'machines/asus/hardware-configuration.nix')
-rw-r--r--machines/asus/hardware-configuration.nix27
1 files changed, 22 insertions, 5 deletions
diff --git a/machines/asus/hardware-configuration.nix b/machines/asus/hardware-configuration.nix
index ef6aaa7..180bfdc 100644
--- a/machines/asus/hardware-configuration.nix
+++ b/machines/asus/hardware-configuration.nix
@@ -10,14 +10,31 @@
 
   boot.initrd.availableKernelModules = [ "xhci_pci" "usb_storage" "usbhid" "sd_mod" "sdhci_acpi" ];
   boot.initrd.kernelModules = [ ];
-  boot.kernelModules = [ "kvm-intel" ];
+  boot.kernelModules = [ "kvm-intel" "brcmfmac" ];
   boot.extraModulePackages = [ ];
 
-  boot.initrd.prepend = [ "${./acpi_override}" ];
+  boot.kernelParams = [ "intel_idle.max_cstate=1" ];
 
-  boot.loader.grub = {
-    efiSupport = true;
-    device = "nodev";
+  boot.initrd.prepend = [ "${./acpi_override}" ];
+  boot.kernelPatches = [
+    {
+      name = "acpi_upgrade";
+      patch = null;
+      extraConfig = ''
+        ACPI_TABLE_UPGRADE y
+      '';
+    }
+  ];
+
+  boot.loader = {
+    efi = {
+      canTouchEfiVariables = true;
+      efiSysMountPoint = "/boot";
+    };
+    grub = {
+      efiSupport = true;
+      device = "nodev";
+    };
   };
 
   fileSystems."/" = lib.mkForce