about summary refs log tree commit diff
path: root/shell.nix
diff options
context:
space:
mode:
Diffstat (limited to 'shell.nix')
-rw-r--r--shell.nix17
1 files changed, 17 insertions, 0 deletions
diff --git a/shell.nix b/shell.nix
new file mode 100644
index 0000000..7dcfe0c
--- /dev/null
+++ b/shell.nix
@@ -0,0 +1,17 @@
+let
+  pkgs = import (builtins.fetchTarball {
+    url = "https://github.com/NixOS/nixpkgs/archive/refs/heads/nixos-21.05-small.tar.gz";
+    sha256 = "18glj62yy0l917092izcby6pdj56yzq8sdh3c525kbf14zqa7q3j";
+  }) { };
+in
+  with pkgs;
+  mkShell {
+    buildInputs = [
+      python37
+      (texlive.combine {
+        inherit (texlive) scheme-minimal pdfcrop pdfjam pdfbook2;
+      })
+      ghostscript
+      (callPackage ./nix/neatroff.nix { })
+    ];
+  }