about summary refs log tree commit diff
path: root/pkgs/larbs/dwmblocks/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/larbs/dwmblocks/default.nix')
-rw-r--r--pkgs/larbs/dwmblocks/default.nix28
1 files changed, 28 insertions, 0 deletions
diff --git a/pkgs/larbs/dwmblocks/default.nix b/pkgs/larbs/dwmblocks/default.nix
new file mode 100644
index 0000000..a8cee04
--- /dev/null
+++ b/pkgs/larbs/dwmblocks/default.nix
@@ -0,0 +1,28 @@
+{ stdenv, fetchgit, libX11, patches ? [] }:
+
+with stdenv.lib;
+
+stdenv.mkDerivation rec {
+  name = "dwmblocks";
+
+  src = fetchgit {
+    url = "https://github.com/LukeSmithXYZ/dwmblocks";
+    rev = "6bbb413fd7fb31b052945061305bf9ac87f0f6fd";
+    sha256 = "0h62avawlkbxjkhjsbzp5afrd5jbjjvnzq73nh3p53p1zpjc18wb";
+  };
+
+  inherit patches;
+
+  buildInputs = [ libX11 ];
+
+  installPhase = ''
+    make install PREFIX=$out
+  '';
+
+  meta = {
+    homepage = "https://github.com/LukeSmithXYZ/dwmblocks";
+    description = "Luke's build of dwmblocks";
+    license = licenses.mit;
+    platforms = platforms.linux;
+  };
+}