about summary refs log tree commit diff
path: root/pkgs/dwmblocks
diff options
context:
space:
mode:
Diffstat (limited to 'pkgs/dwmblocks')
-rw-r--r--pkgs/dwmblocks/config.h36
-rw-r--r--pkgs/dwmblocks/default.nix3
2 files changed, 38 insertions, 1 deletions
diff --git a/pkgs/dwmblocks/config.h b/pkgs/dwmblocks/config.h
new file mode 100644
index 0000000..b40020e
--- /dev/null
+++ b/pkgs/dwmblocks/config.h
@@ -0,0 +1,36 @@
+//Modify this file to change what commands output to your statusbar, and recompile using the make command.
+static const Block blocks[] = {
+	/*Icon*/	/*Command*/		/*Update Interval*/	/*Update Signal*/
+	/* {"⌨", "sb-kbselect", 0, 30}, */
+	{"", "cat /tmp/recordingicon 2>/dev/null",	0,	9},
+	{"",	"sb-tasks",	10,	26},
+	{"",	"sb-music",	0,	11},
+	/* {"",	"sb-pacpackages",	0,	8}, */
+	/* {"",	"sb-news",		0,	6}, */
+	/* {"",	"sb-price lbc \"LBRY Token\" 📚",			9000,	22}, */
+	{"",	"sb-price bat \"Basic Attention Token\" 🦁",	9000,	20},
+	/* {"",	"sb-price link \"Chainlink\" 🔗",			300,	25}, */
+	/* {"",	"sb-price xmr \"Monero\" 🔒",			9000,	24}, */
+	/* {"",	"sb-price eth Ethereum 🍸",	9000,	23}, */
+	{"",	"sb-price btc Bitcoin 💰",				9000,	21},
+	{"",	"sb-torrent",	20,	7},
+	{"",	"sb-memory",	10,	14},
+	{"",	"sb-cpu",		10,	18},
+	/* {"",	"sb-moonphase",	18000,	17}, */
+	{"",	"sb-forecast",	18000,	5},
+	{"",	"sb-mailbox",	180,	12},
+	{"",	"sb-nettraf",	1,	16},
+	{"",	"sb-volume",	0,	10},
+	{"",	"sb-battery",	5,	3},
+	{"",	"sb-clock",	10,	1},
+	{"",	"sb-internet",	5,	4},
+	/* {"",	"sb-help-icon",	0,	15}, */
+};
+
+//Sets delimiter between status commands. NULL character ('\0') means no delimiter.
+static char *delim = " ";
+
+// Have dwmblocks automatically recompile and run when you edit this file in
+// vim with the following line in your vimrc/init.vim:
+
+// autocmd BufWritePost ~/.local/src/dwmblocks/config.h !cd ~/.local/src/dwmblocks/; sudo make install && { killall -q dwmblocks;setsid dwmblocks & }
diff --git a/pkgs/dwmblocks/default.nix b/pkgs/dwmblocks/default.nix
index d582780..ecc3b5b 100644
--- a/pkgs/dwmblocks/default.nix
+++ b/pkgs/dwmblocks/default.nix
@@ -1,7 +1,8 @@
 pkgs:
   pkgs.nur.repos.pn.dwmblocks.override {
     patches = [
-      ./dwmblocks.diff
+      #./dwmblocks.diff
       # ./dwmblocks-todo.diff
     ];
+    config_h = ./config.h;
   }