about summary refs log tree commit diff
path: root/modules/dockd.nix
diff options
context:
space:
mode:
Diffstat (limited to 'modules/dockd.nix')
-rw-r--r--modules/dockd.nix92
1 files changed, 0 insertions, 92 deletions
diff --git a/modules/dockd.nix b/modules/dockd.nix
deleted file mode 100644
index e2b5870..0000000
--- a/modules/dockd.nix
+++ /dev/null
@@ -1,92 +0,0 @@
-{ config, lib, pkgs, ... }:
-
-let
-  cfg = config.programs.dockd;
-in
-
-{
-  options = {
-    programs.dockd = {
-      enable = lib.mkOption {
-        type = lib.types.bool;
-        default = false;
-        description = ''
-          ThinkPad dock manager daemon.
-        '';
-      };
-    };
-  };
-
-  config = lib.mkIf (cfg.enable) {
-    environment.systemPackages = [ pkgs.nur.repos.pn.dockd ];
-    environment.etc = {
-      "dockd/docked.conf".text = ''
-[Screen]
-height=1080
-width=1920
-mm_height=282
-mm_width=502
-
-[CRTC]
-crtc=63
-x=0
-y=0
-rotation=1
-mode=None
-outputs_len=0
-
-[CRTC]
-crtc=64
-x=0
-y=0
-rotation=1
-mode=1920x1080
-outputs_len=1
-outputs_0=DP2
-
-[CRTC]
-crtc=65
-x=0
-y=0
-rotation=1
-mode=None
-outputs_len=0
-
-     '';
-      "dockd/undocked.conf".text = ''
-[Screen]
-height=768
-width=1366
-mm_height=201
-mm_width=359
-
-[CRTC]
-crtc=63
-x=0
-y=0
-rotation=1
-mode=1366x768
-outputs_len=1
-outputs_0=LVDS1
-
-[CRTC]
-crtc=64
-x=1920
-y=0
-rotation=1
-mode=None
-outputs_len=0
-
-[CRTC]
-crtc=65
-x=0
-y=0
-rotation=1
-mode=None
-outputs_len=0
-
-
-     '';
-    };
-  };
-}