about summary refs log tree commit diff
path: root/machines/t14/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'machines/t14/default.nix')
-rw-r--r--machines/t14/default.nix15
1 files changed, 1 insertions, 14 deletions
diff --git a/machines/t14/default.nix b/machines/t14/default.nix
index 506b05f..f258a4c 100644
--- a/machines/t14/default.nix
+++ b/machines/t14/default.nix
@@ -1,7 +1,5 @@
 { config, pkgs, ... }:
-let
-	rebuild = pkgs.writeShellScriptBin "rebuild" (builtins.readFile ../../rebuild.sh);
-in {
+{
 	imports =
 		[ # Include the results of the hardware scan.
 		../base.nix
@@ -37,21 +35,10 @@ in {
 	programs.nano.enable = false;
 	programs.git.enable = true;
 
-	boot.plymouth.enable = true;
-
 # Allow unfree packages
 	nixpkgs.config.allowUnfree = true;
-	nix.settings.experimental-features = [ "flakes" "nix-command" ];
 	nix.optimise.automatic = true;
 
-# List packages installed in system profile. To search, run:
-# $ nix search wget
-	environment.systemPackages = with pkgs; [
-#  vim # Do not forget to add an editor to edit configuration.nix! The Nano editor is also installed by default.
-#  wget
-		rebuild
-	];
-
 # Some programs need SUID wrappers, can be configured further or are
 # started in user sessions.
 # programs.mtr.enable = true;