about summary refs log tree commit diff
path: root/machines/t14/default.nix
diff options
context:
space:
mode:
Diffstat (limited to 'machines/t14/default.nix')
-rw-r--r--machines/t14/default.nix26
1 files changed, 18 insertions, 8 deletions
diff --git a/machines/t14/default.nix b/machines/t14/default.nix
index 96937c1..e396796 100644
--- a/machines/t14/default.nix
+++ b/machines/t14/default.nix
@@ -20,15 +20,15 @@
 
 	i18n.extraLocaleSettings = {
 		LC_ALL = "en_US.UTF-8";
-		LC_ADDRESS = "en_US.UTF-8";
-		LC_IDENTIFICATION = "en_US.UTF-8";
-		LC_MEASUREMENT = "en_US.UTF-8";
-		LC_MONETARY = "en_US.UTF-8";
-		LC_NAME = "en_US.UTF-8";
+		LC_ADDRESS = "pl_PL.UTF-8";
+		LC_IDENTIFICATION = "pl_PL.UTF-8";
+		LC_MEASUREMENT = "pl_PL.UTF-8";
+		LC_MONETARY = "pl_PL.UTF-8";
+		LC_NAME = "en_IE.UTF-8";
 		LC_NUMERIC = "en_US.UTF-8";
-		LC_PAPER = "en_US.UTF-8";
-		LC_TELEPHONE = "en_US.UTF-8";
-		LC_TIME = "en_US.UTF-8";
+		LC_PAPER = "pl_PL.UTF-8";
+		LC_TELEPHONE = "pl_PL.UTF-8";
+		LC_TIME = "pl_PL.UTF-8";
 	};
 
 	programs.vim.defaultEditor = true;
@@ -37,6 +37,10 @@
 
 # Allow unfree packages
 	nixpkgs.config.allowUnfree = true;
+	nix.gc = {
+		automatic = true;
+		options = "--delete-older-than 30d";
+	};
 	nix.optimise.automatic = true;
 	nix.settings.trusted-users = [ "@wheel" ];
 
@@ -51,6 +55,12 @@
   services.printing.drivers = with pkgs; [ cnijfilter2 ];
 
 
+	programs.appimage = {
+		enable = true;
+		binfmt = true;
+	};
+
+
 # Open ports in the firewall.
 # networking.firewall.allowedTCPPorts = [ ... ];
 # networking.firewall.allowedUDPPorts = [ ... ];